<!DOCTYPE html><!--[if IE 7]>
<html class="ie ie7" lang="en" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
    <head>
        <meta charset="UTF-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <script>var et_site_url='https://www.thunder1320.com';var et_post_id='108303';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Ruby L. Honea &#8211; Thunder Radio</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Thunder Radio &raquo; Feed" href="https://www.thunder1320.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Thunder Radio &raquo; Comments Feed" href="https://www.thunder1320.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thunder1320.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.thunder1320.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='https://www.thunder1320.com/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css?ver=0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='https://www.thunder1320.com/wp-content/plugins/photo-gallery/css/sumoselect.min.css?ver=3.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='https://www.thunder1320.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css?ver=2.5.61' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_googlefonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu&#038;subset=greek,latin,greek-ext,vietnamese,cyrillic-ext,latin-ext,cyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='https://www.thunder1320.com/wp-content/plugins/photo-gallery/css/styles.min.css?ver=2.5.61' type='text/css' media='all' />
<link rel='stylesheet' id='simple-banner-style-css'  href='https://www.thunder1320.com/wp-content/plugins/simple-banner/simple-banner.css?ver=2.10.0' type='text/css' media='all' />
<link rel='stylesheet' id='ssb-front-css-css'  href='https://www.thunder1320.com/wp-content/plugins/simple-social-buttons/assets/css/front.css?ver=3.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.thunder1320.com/wp-content/themes/graphene/bootstrap/css/bootstrap.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.thunder1320.com/wp-content/themes/graphene/fonts/font-awesome/css/font-awesome.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='graphene-css'  href='https://www.thunder1320.com/wp-content/themes/graphene/style.css?ver=2.8.4' type='text/css' media='screen' />
<link rel='stylesheet' id='graphene-responsive-css'  href='https://www.thunder1320.com/wp-content/themes/graphene/responsive.css?ver=2.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='graphene-blocks-css'  href='https://www.thunder1320.com/wp-content/themes/graphene/blocks.css?ver=2.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-modules-style-css'  href='https://www.thunder1320.com/wp-content/plugins/divi-builder/includes/builder/styles/frontend-builder-plugin-style.unified.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.thunder1320.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.thunder1320.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/photo-gallery/js/jquery.lazy.min.js?ver=2.5.61' id='bwg_lazyload-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.3' id='sumoselect-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.3.2' id='jquery-mobile-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=2.5.61' id='mCustomScrollbar-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js?ver=0.4.1' id='jquery-fullscreen-js'></script>
<script type='text/javascript' id='bwg_frontend-js-extra'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"1","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"1","lazy_loader":"https:\/\/www.thunder1320.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=2.5.61' id='bwg_frontend-js'></script>
<script type='text/javascript' id='simple-banner-script-js-extra'>
/* <![CDATA[ */
var scriptParams = {"version":"2.10.0","hide_simple_banner":"","simple_banner_position":"","header_margin":"","header_padding":"","simple_banner_text":"Listen to your hometown station from your phone or your computer!  <a href=\"https:\/\/bit.ly\/streamthunder\">Click here to listen<\/a>","pro_version_enabled":"","disabled_on_current_page":"","debug_mode":"","id":"108303","disabled_pages_array":[],"post_object":[{"ID":108303,"post_author":"3","post_date":"2021-06-20 09:25:43","post_date_gmt":"2021-06-20 14:25:43","post_content":"<!-- wp:paragraph -->\n<p>Ruby L. Honea, of Tullahoma, passed this life on June 18, 2021 at her residence at the age of 81. The family will welcome friends for Visitation on Monday, June 21, 2021 from 10:00am until 12:00pm. Funeral Services will immediately follow, beginning at 12:00pm and will be officiated by Rev. Brian Ferrell and Bro. James Taylor. Interment will follow at Rose Hill Memorial Gardens.<\/p>\n<!-- \/wp:paragraph -->\n\n<!-- wp:image {\"align\":\"right\",\"id\":108304,\"width\":152,\"height\":152,\"sizeSlug\":\"large\",\"linkDestination\":\"media\"} -->\n<div class=\"wp-block-image\"><figure class=\"alignright size-large is-resized\"><a href=\"https:\/\/www.thunder1320.com\/wp-content\/uploads\/2021\/06\/Ruby-Honea-1624183833.jpeg\"><img src=\"https:\/\/www.thunder1320.com\/wp-content\/uploads\/2021\/06\/Ruby-Honea-1624183833.jpeg\" alt=\"\" class=\"wp-image-108304\" width=\"152\" height=\"152\"\/><\/a><\/figure><\/div>\n<!-- \/wp:image -->\n\n<!-- wp:paragraph -->\n<p><br>Mrs. Honea was born in Franklin County to the late Grady Hastings and Vina Sanders Hastings. She was a faithful member of the First Church of Jesus Christ and loved the Lord with all her heart. She enjoyed canning, eating good food such as fried chicken, and traveling the world with her late husband, H.E.. Mrs. Honea was very family oriented and made sure to be at any family get-together that she could; always encouraging her brother to pick up his guitar and play for everyone. Most of all, she enjoyed being with her children and grandchildren.<br>In addition to her parents and husband, she was preceded in death by her son, Andy Bradford Jr; sister, Lorene Walls; granddaughter, Alicia Rodriguez.<br>She is survived by her son, Roy (Sandra) Bradford; brother, Orvel (Sue) Hastings; sister, Frances Ferrell; grandchildren, Jason Bradford, AJ Bradford, Christopher Bradford, Chrystal Escamilla, Grady Bradford; 13 great-grandchildren.<\/p>\n<!-- \/wp:paragraph -->","post_title":"Ruby L. Honea","post_excerpt":"","post_status":"publish","comment_status":"closed","ping_status":"closed","post_password":"","post_name":"ruby-l-honea","to_ping":"","pinged":"","post_modified":"2021-06-20 09:25:44","post_modified_gmt":"2021-06-20 14:25:44","post_content_filtered":"","post_parent":0,"guid":"https:\/\/www.thunder1320.com\/?p=108303","menu_order":0,"post_type":"post","post_mime_type":"","comment_count":"0","filter":"raw"}],"is_current_page_a_post":"1","disabled_on_posts":"","simple_banner_font_size":"","simple_banner_color":"#ffff00","simple_banner_text_color":"#000000","simple_banner_link_color":"#0000ff","simple_banner_close_color":"","simple_banner_custom_css":"","simple_banner_scrolling_custom_css":"","simple_banner_text_custom_css":"","simple_banner_button_css":"","site_custom_css":"","keep_site_custom_css":"","site_custom_js":"","keep_site_custom_js":"","wp_body_open_enabled":"","wp_body_open":"1","close_button_enabled":"","close_button_expiration":"","close_button_cookie_set":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/simple-banner/simple-banner.js?ver=2.10.0' id='simple-banner-script-js'></script>
<script type='text/javascript' id='ssb-front-js-js-extra'>
/* <![CDATA[ */
var SSB = {"ajax_url":"https:\/\/www.thunder1320.com\/wp-admin\/admin-ajax.php","fb_share_nonce":"7b4b6c8bd2"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/simple-social-buttons/assets/js/front.js?ver=3.2.2' id='ssb-front-js-js'></script>
<script defer type='text/javascript' src='https://www.thunder1320.com/wp-content/themes/graphene/bootstrap/js/bootstrap.min.js?ver=2.8.4' id='bootstrap-js'></script>
<script defer type='text/javascript' src='https://www.thunder1320.com/wp-content/themes/graphene/js/bootstrap-hover-dropdown/bootstrap-hover-dropdown.min.js?ver=2.8.4' id='bootstrap-hover-dropdown-js'></script>
<script defer type='text/javascript' src='https://www.thunder1320.com/wp-content/themes/graphene/js/bootstrap-submenu/bootstrap-submenu.min.js?ver=2.8.4' id='bootstrap-submenu-js'></script>
<script defer type='text/javascript' src='https://www.thunder1320.com/wp-content/themes/graphene/js/jquery.infinitescroll.min.js?ver=2.8.4' id='infinite-scroll-js'></script>
<script type='text/javascript' id='graphene-js-extra'>
/* <![CDATA[ */
var grapheneJS = {"siteurl":"https:\/\/www.thunder1320.com","ajaxurl":"https:\/\/www.thunder1320.com\/wp-admin\/admin-ajax.php","templateUrl":"https:\/\/www.thunder1320.com\/wp-content\/themes\/graphene","isSingular":"1","enableStickyMenu":"","shouldShowComments":"","commentsOrder":"newest","sliderDisable":"1","sliderInterval":"7000","infScrollBtnLbl":"Load more","infScrollOn":"","infScrollCommentsOn":"","totalPosts":"1","postsPerPage":"10","isPageNavi":"","infScrollMsgText":"Fetching window.grapheneInfScrollItemsPerPage of window.grapheneInfScrollItemsLeft items left ...","infScrollMsgTextPlural":"Fetching window.grapheneInfScrollItemsPerPage of window.grapheneInfScrollItemsLeft items left ...","infScrollFinishedText":"All loaded!","commentsPerPage":"50","totalComments":"0","infScrollCommentsMsg":"Fetching window.grapheneInfScrollCommentsPerPage of window.grapheneInfScrollCommentsLeft comments left ...","infScrollCommentsMsgPlural":"Fetching window.grapheneInfScrollCommentsPerPage of window.grapheneInfScrollCommentsLeft comments left ...","infScrollCommentsFinishedMsg":"All comments loaded!","disableLiveSearch":"1","txtNoResult":"No result found.","isMasonry":""};
/* ]]> */
</script>
<script defer type='text/javascript' src='https://www.thunder1320.com/wp-content/themes/graphene/js/graphene.js?ver=2.8.4' id='graphene-js'></script>
<link rel="https://api.w.org/" href="https://www.thunder1320.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.thunder1320.com/wp-json/wp/v2/posts/108303" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thunder1320.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thunder1320.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel="canonical" href="https://www.thunder1320.com/obit/ruby-l-honea/" />
<link rel='shortlink' href='https://www.thunder1320.com/?p=108303' />
<link rel="alternate" type="application/json+oembed" href="https://www.thunder1320.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thunder1320.com%2Fobit%2Fruby-l-honea%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thunder1320.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thunder1320.com%2Fobit%2Fruby-l-honea%2F&#038;format=xml" />
<style type="text/css" media="screen">.simple-banner{background:#ffff00;}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text{color:#000000;}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text a{color:#0000ff;}</style><style id="simple-banner-site-custom-css-dummy" type="text/css" media="screen"></style><script id="simple-banner-site-custom-js-dummy" type="text/javascript"></script> <style media="screen">

		 /*inline margin*/
		.simplesocialbuttons.simplesocialbuttons_inline.simplesocial-sm-round button{
	  margin: ;
	}
	
	
	
	
	
	
			 /*margin-digbar*/

	
	
	
	
	
	
	
</style>

<!-- Open Graph Meta Tags generated by Simple Social Buttons 3.2.2 -->
<meta property="og:title" content="Ruby L. Honea - Thunder Radio" />
<meta property="og:description" content="Ruby L. Honea, of Tullahoma, passed this life on June 18, 2021 at her residence at the age of 81. The family will welcome friends for Visitation on Monday, June 21, 2021 from 10:00am until 12:00pm. Funeral Services will immediately follow, beginning at 12:00pm and will be officiated by Rev. Brian Ferrell and Bro. James Taylor. Interment will follow at" />
<meta property="og:url" content="https://www.thunder1320.com/obit/ruby-l-honea/" />
<meta property="og:site_name" content="Thunder Radio" />
<meta property="og:image" content="https://www.thunder1320.com/wp-content/uploads/2021/06/Ruby-Honea-1624183833.jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Ruby L. Honea, of Tullahoma, passed this life on June 18, 2021 at her residence at the age of 81. The family will welcome friends for Visitation on Monday, June 21, 2021 from 10:00am until 12:00pm. Funeral Services will immediately follow, beginning at 12:00pm and will be officiated by Rev. Brian Ferrell and Bro. James Taylor. Interment will follow at" />
<meta name="twitter:title" content="Ruby L. Honea - Thunder Radio" />
<meta property="twitter:image" content="https://www.thunder1320.com/wp-content/uploads/2021/06/Ruby-Honea-1624183833.jpeg" />
<link rel="preload" href="https://www.thunder1320.com/wp-content/plugins/divi-builder/core/admin/fonts/modules.ttf" as="font" crossorigin="anonymous">		<script>
		   WebFontConfig = {
		      google: { 
		      	families: ["Lato:400,400i,700,700i&display=swap"]		      }
		   };

		   (function(d) {
		      var wf = d.createElement('script'), s = d.scripts[0];
		      wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
		      wf.async = true;
		      s.parentNode.insertBefore(wf, s);
		   })(document);
		</script>
	<style type="text/css">
.top-bar{background-color:#000000} .top-bar .searchform .btn-default, .top-bar #top_search .searchform .btn-default{color:#000000}.navbar {background: #212121} @media only screen and (max-width: 768px){ #mega-menu-wrap-Header-Menu .mega-menu-toggle + #mega-menu-Header-Menu {background: #212121} }#content, body > .container > .panel-layout, #header {background-color: #000000}a, .post .date .day, .pagination>li>a, .pagination>li>a:hover, .pagination>li>span, #comments > h4.current a, #comments > h4.current a .fa, .post-nav-top p, .post-nav-top a, .autocomplete-suggestions strong {color: #1e73be}a:focus, a:hover, .post-nav-top a:hover {color: #1e3ebf}.sticky {border-color: #4f2d69}.sidebar .sidebar-wrap {background-color: #2d2d2d; border-color: #2d2d2d}.btn, .btn:focus, .btn:hover, .btn a, .Button, .colour-preview .button, input[type="submit"], button[type="submit"], #commentform #submit, .wpsc_buy_button, #back-to-top, .wp-block-button .wp-block-button__link:not(.has-background) {background: #dd3333; color: #ffffff}.label-primary, .pagination>.active>a, .pagination>.active>a:focus, .pagination>.active>a:hover, .pagination>.active>span, .pagination>.active>span:focus, .pagination>.active>span:hover, .list-group-item.parent, .list-group-item.parent:focus, .list-group-item.parent:hover {background: #4F2D69; border-color: #4F2D69; color: #000000}.archive-title span {color: #ffffff}.header_title, .header_title a, .header_title a:visited, .header_title a:hover, .header_desc {color:#blank}.carousel, .carousel .item{height:400px}@media (max-width: 991px) {.carousel, .carousel .item{height:250px}}#header{max-height:100px}
</style>
		<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":"https:\/\/www.thunder1320.com\/obit\/ruby-l-honea\/","publisher":{"@type":"Organization","name":"Thunder Radio"},"headline":"Ruby L. Honea","datePublished":"2021-06-20T09:25:43+00:00","dateModified":"2021-06-20T09:25:44+00:00","description":"Ruby L. Honea, of Tullahoma, passed this life on June 18, 2021 at her residence at the age of 81. The family will welcome friends for Visitation on Monday, June 21, 2021 from 10:00am until 12:00pm. Funeral Services will immediately follow, beginning at 12:00pm and will be officiated by Rev. Brian Ferrell and Bro. James ...","author":{"@type":"Person","name":"Josh Peterson"},"image":["https:\/\/www.thunder1320.com\/wp-content\/uploads\/2021\/06\/Ruby-Honea-1624183833.jpeg"]}</script>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://www.thunder1320.com/wp-content/themes/graphene/images/bg.jpg"); background-position: center top; background-size: contain; background-repeat: no-repeat; background-attachment: scroll; }
</style>
	<meta property="og:type" content="article" />
<meta property="og:title" content="Ruby L. Honea" />
<meta property="og:url" content="https://www.thunder1320.com/obit/ruby-l-honea/" />
<meta property="og:site_name" content="Thunder Radio" />
<meta property="og:description" content="Ruby L. Honea, of Tullahoma, passed this life on June 18, 2021 at her residence at the age of 81. The family will welcome friends for Visitation on Monday, June 21, 2021 from 10:00am until 12:00pm. Funeral Services will immediately follow, beginning at 12:00pm and will be officiated by Rev. Brian Ferrell and Bro. James ..." />
<meta property="og:updated_time" content="2021-06-20T09:25:44+00:00" />
<meta property="article:modified_time" content="2021-06-20T09:25:44+00:00" />
<meta property="article:published_time" content="2021-06-20T09:25:43+00:00" />
<meta property="og:image" content="https://www.thunder1320.com/wp-content/uploads/2021/06/Ruby-Honea-1624183833.jpeg" />
<meta property="og:image:width" content="207" />
<meta property="og:image:height" content="207" />
<meta name="apple-itunes-app" content="app-id=988398905, affiliate-data=myAffiliateData, app-argument=https://www.thunder1320.com">

<script type="text/javascript">
jQuery(document).ready(function(){
var item = document.querySelector('.et_pb_slider .et_pb_slides');
if(item!=null){
for (var i = item.children.length; i >= 0; i--) {
item.appendChild(item.children[Math.random() * i | 0]);
}
}
});
</script>		<style type="text/css" id="wp-custom-css">
			
#previous, #previous a, #previous a:visited, #next-post, #next-post a, #next-post a:visited {
    color: #000000;
    font: 12px tahoma;
	text-decoration: none;}
    
    #secondary {
 background: #4c4c4c;
}
    
    #sidebar {
  background:#4c4c4c;
        
}

/* Added to make the homepage a static page */
body.home .post-title.entry-title {
    display: none;
}

body.home .homepage_panes.row {
    display: none;
}

/* Added to reset the padding on individual post pages */ 
.post .entry, .singular .posts-list .post .entry {
    padding: 5px 15px 0 15px !important;
}

/* Added to minimize the padding on the right add column 
.widget-area .sidebar-wrap {
    border-top: 0;
    padding-top: 15px;
}
.sidebar p {
	margin-top: 0;
}*/

/* 3/4/2020 JL: Added to put the ads on the right of the obit page */
.page-id-12 #content-main {
	width: 75%;
	float: left;
	padding-left: 10px;
	padding-right: 10px;
}

.page-id-12 #sidebar1 {
	width: 25%;
	float: left;
	padding-left: 0;
	padding-right: 10px;
}

.page-id-12 #sidebar1 img {
	max-width: 100%;
}

.page-id-12 #sidebar1 > div {
    padding: 0;
    border-top: none;
}

.page-id-12 .entry {
	padding: 0 5px!important;
}		</style>
		    </head>
    <body data-rsssl=1 class="post-template-default single single-post postid-108303 single-format-standard custom-background wp-embed-responsive et_divi_builder layout-boxed two_col_left two-columns singular unequal-content-bgs et-pb-theme-graphene et-db et_minified_js et_minified_css">
        
        <div class="container boxed-wrapper">
            
                            <div id="top-bar" class="row clearfix top-bar ">
                    
                                                    
                            <div class="col-md-12 top-bar-items">
                                
                                                                                                    	<ul class="social-profiles">
							
			            <li class="social-profile social-profile-twitter">
			            	<a href="https://twitter.com/WMSRradio" title="Twitter" id="social-id-1" class="mysocial social-twitter" target="_blank">
			            				                            <i class="fa fa-twitter"></i>
		                        			            	</a>
			            </li>
		            
		    						
			            <li class="social-profile social-profile-facebook">
			            	<a href="https://www.facebook.com/WMSRradio" title="Facebook" id="social-id-2" class="mysocial social-facebook" target="_blank">
			            				                            <i class="fa fa-facebook"></i>
		                        			            	</a>
			            </li>
		            
		    						
			            <li class="social-profile social-profile-youtube">
			            	<a href="https://www.youtube.com/user/WMSRradio" title="YouTube" id="social-id-3" class="mysocial social-youtube" target="_blank">
			            				                            <i class="fa fa-youtube"></i>
		                        			            	</a>
			            </li>
		            
		    	    </ul>
                                    
                                                                    <button type="button" class="search-toggle navbar-toggle collapsed" data-toggle="collapse" data-target="#top_search">
                                        <span class="sr-only">Toggle search form</span>
                                        <i class="fa fa-search-plus"></i>
                                    </button>

                                    <div id="top_search" class="top-search-form">
                                        <form class="searchform" method="get" action="https://www.thunder1320.com">
	<div class="input-group">
		<div class="form-group live-search-input">
			<label for="s" class="screen-reader-text">Search for:</label>
		    <input type="text" id="s" name="s" class="form-control" placeholder="Search">
		    		</div>
	    <span class="input-group-btn">
	    	<button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button>
	    </span>
    </div>
    </form>                                                                            </div>
                                
                                                            </div>

                        
                                    </div>
            

            <div id="header" class="row">

                                
                                    <div class="header-widget"><div id="text-4" class="sidebar-wrap widget_text">			<div class="textwidget"><a href="https://bit.ly/streamthunder"><img src="https://www.thunder1320.com/wp-content/uploads/2021/06/web_top-banner_phrase-2021-1.jpg" alt="" title="" /></a></div>
		</div></div>                            </div>


                        <nav class="navbar row navbar-inverse">

                <div class="navbar-header align-center">
                		                    <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#header-menu-wrap, #secondary-menu-wrap">
	                        <span class="sr-only">Toggle navigation</span>
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                    </button>
                	                    
                    
                                            <p class="header_title mobile-only">
                            <a href="https://www.thunder1320.com" title="Go back to the front page">                                Thunder Radio                            </a>                        </p>
                    
                                            
                                    </div>

                                    <div class="collapse navbar-collapse" id="header-menu-wrap">

            			<ul id="header-menu" class="nav navbar-nav flip"><li id="menu-item-8" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-8"><a href="https://www.thunder1320.com" class="has-icon"><i class="fa fa-https://www.thunder1320.com/wp-content/plugins/wptouch-pro/resources/icons/elegant/home.png"></i> Home</a></li>
<li id="menu-item-89417" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89417"><a href="https://www.thunder1320.com/news-2/">News</a></li>
<li id="menu-item-89415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89415"><a href="https://www.thunder1320.com/sports/">Sports</a></li>
<li id="menu-item-89414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89414"><a href="https://www.thunder1320.com/obituaries/">Obituaries</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://www.thunder1320.com/category/birthdays/" class="has-icon"><i class="fa fa-https://www.thunder1320.com/wp-content/plugins/wptouch-pro/resources/icons/elegant/paper.png"></i> Birthdays</a></li>
<li id="menu-item-89918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89918"><a href="https://www.thunder1320.com/community-calendar/">Community Calendar</a></li>
<li id="menu-item-20037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20037"><a href="https://www.thunder1320.com/downloads/" class="has-icon"><i class="fa fa-https://www.thunder1320.com/wp-content/plugins/wptouch-pro/resources/icons/elegant/paper.png"></i> Downloads</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://www.thunder1320.com/contact/advertise/" class="has-icon"><i class="fa fa-https://www.thunder1320.com/wp-content/plugins/wptouch-pro/resources/icons/elegant/paper.png"></i> Get your business on Thunder</a></li>
<li id="menu-item-88723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88723"><a href="https://www.thunder1320.com/on-air-schedule/">On-Air Schedule</a></li>
<li id="menu-item-94115" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94115"><a href="https://www.thunder1320.com/greatguarantee/">GREAT advertising guarantee</a></li>
<li id="menu-item-95079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95079"><a href="https://www.thunder1320.com/websites/">Get my own business website</a></li>
<li id="menu-item-103928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-103928"><a href="https://www.thunder1320.com/loyal-listener-club/">Loyal Listener Club</a></li>
</ul>                        
            			                        
                                            </div>
                
                                    
                            </nav>

            
            <div id="content" class="clearfix hfeed row">
                
                    
                                        
                    <div id="content-main" class="clearfix content-main col-md-9">
                    
	
		<div class="post-nav post-nav-top clearfix">
			<p class="previous col-sm-6"><i class="fa fa-arrow-circle-left"></i> <a href="https://www.thunder1320.com/birthdays/birthdays-june-18/" rel="prev">Birthdays- June 18</a></p>			<p class="next-post col-sm-6"><a href="https://www.thunder1320.com/news/first-vision-bank-welcomes-vice-president-for-manchester-office/" rel="next">First Vision Bank welcomes Vice President for Manchester office</a> <i class="fa fa-arrow-circle-right"></i></p>					</div>
		        
<div id="post-108303" class="clearfix post post-108303 type-post status-publish format-standard has-post-thumbnail hentry category-obit nodate item-wrap">
		
	<div class="entry clearfix">
    	
                        
		        <h1 class="post-title entry-title">
			Ruby L. Honea			        </h1>
		
		
				
				<div class="entry-content clearfix">
							
										
						
<p>Ruby L. Honea, of Tullahoma, passed this life on June 18, 2021 at her residence at the age of 81. The family will welcome friends for Visitation on Monday, June 21, 2021 from 10:00am until 12:00pm. Funeral Services will immediately follow, beginning at 12:00pm and will be officiated by Rev. Brian Ferrell and Bro. James Taylor. Interment will follow at Rose Hill Memorial Gardens.</p>



<div class="wp-block-image"><figure class="alignright size-large is-resized"><a href="https://www.thunder1320.com/wp-content/uploads/2021/06/Ruby-Honea-1624183833.jpeg"><img loading="lazy" src="https://www.thunder1320.com/wp-content/uploads/2021/06/Ruby-Honea-1624183833.jpeg" alt="" class="wp-image-108304" width="152" height="152" srcset="https://www.thunder1320.com/wp-content/uploads/2021/06/Ruby-Honea-1624183833.jpeg 207w, https://www.thunder1320.com/wp-content/uploads/2021/06/Ruby-Honea-1624183833-150x150.jpeg 150w" sizes="(max-width: 152px) 100vw, 152px" /></a></figure></div>



<p><br>Mrs. Honea was born in Franklin County to the late Grady Hastings and Vina Sanders Hastings. She was a faithful member of the First Church of Jesus Christ and loved the Lord with all her heart. She enjoyed canning, eating good food such as fried chicken, and traveling the world with her late husband, H.E.. Mrs. Honea was very family oriented and made sure to be at any family get-together that she could; always encouraging her brother to pick up his guitar and play for everyone. Most of all, she enjoyed being with her children and grandchildren.<br>In addition to her parents and husband, she was preceded in death by her son, Andy Bradford Jr; sister, Lorene Walls; granddaughter, Alicia Rodriguez.<br>She is survived by her son, Roy (Sandra) Bradford; brother, Orvel (Sue) Hastings; sister, Frances Ferrell; grandchildren, Jason Bradford, AJ Bradford, Christopher Bradford, Chrystal Escamilla, Grady Bradford; 13 great-grandchildren.</p>
<div class="simplesocialbuttons simplesocial-sm-round simplesocialbuttons_inline simplesocialbuttons-align-left post-108303 post  simplesocialbuttons-inline-no-animation">
<button class="simplesocial-fb-share" target="_blank" data-href="https://www.facebook.com/sharer/sharer.php?u=https://www.thunder1320.com/obit/ruby-l-honea/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Facebook </span> </button>
<button class="simplesocial-twt-share" data-href="https://twitter.com/share?text=Ruby+L.+Honea&url=https://www.thunder1320.com/obit/ruby-l-honea/" rel="nofollow" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Twitter</span> </button>
<button target="popup" class="simplesocial-linkedin-share" data-href="https://www.linkedin.com/cws/share?url=https://www.thunder1320.com/obit/ruby-l-honea/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">LinkedIn</span></button>
</div>
								</div>
		
			</div>

</div>







            
  

                </div><!-- #content-main -->
        
            
<div id="sidebar1" class="sidebar sidebar-right widget-area col-md-3">

	
        
        
    
</div><!-- #sidebar1 -->        
        
    </div><!-- #content -->


    
        
    <div id="sidebar_bottom" class="sidebar widget-area row footer-widget-col-3">
                    		
            </div>

	

<div id="footer" class="row default-footer">
    
        
            
            <div class="copyright-developer">
                                    <div id="copyright">
                        <p><a href="https://publicfiles.fcc.gov/am-profile/wmsr" target="_blank">WMSR-AM OPIF</a></p>
                    </div>
                
                                    <div id="developer">
                        <p>
                                                        Made with <i class="fa fa-heart"></i> by <a href="https://www.graphene-theme.com/" rel="nofollow">Graphene Themes</a>.                        </p>

                                            </div>
                            </div>

        
                
    </div><!-- #footer -->


</div><!-- #container -->

<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/divi-builder/core/admin/js/es6-promise.auto.min.js?ver=4.9.4' id='es6-promise-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcbvPcUAAAAAAFMCU_q5QNswLW3CT6UeGq0BaIY&#038;ver=4.9.4' id='et-recaptcha-v3-js'></script>
<script type='text/javascript' id='et-core-api-spam-recaptcha-js-extra'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"6LcbvPcUAAAAAAFMCU_q5QNswLW3CT6UeGq0BaIY","page_action":{"action":"ruby_l_honea"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/divi-builder/core/admin/js/recaptcha.js?ver=4.9.4' id='et-core-api-spam-recaptcha-js'></script>
<script type='text/javascript' id='divi-builder-custom-script-js-extra'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"https:\/\/www.thunder1320.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.thunder1320.com\/wp-content\/themes\/graphene\/images","builder_images_uri":"https:\/\/www.thunder1320.com\/wp-content\/plugins\/divi-builder\/includes\/builder\/images","et_frontend_nonce":"efd7bf0d5d","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"b9637a5b2a","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"108303","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""}; var et_builder_utils_params = {"condition":{"diviTheme":false,"extraTheme":false},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
var et_pb_motion_elements = {"desktop":[],"tablet":[],"phone":[]};
var et_pb_sticky_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/divi-builder/js/divi-builder.min.js?ver=4.9.4' id='divi-builder-custom-script-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-content/plugins/divi-builder/core/admin/js/common.js?ver=4.9.4' id='et-core-common-js'></script>
<script type='text/javascript' src='https://www.thunder1320.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript'>function initTwitCount(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://static1.twitcount.com/js/twitcount.js';fjs.parentNode.insertBefore(js,fjs)}}
        var ssb_twit_count_init=!1;addEventListener('mouseover',function(event){if(!ssb_twit_count_init){initTwitCount(document,'script','twitcount_plugins')
        ssb_twit_count_init=!0}})</script></body>
</html>